The Payment Card Industry Security Standards Council (PCI SSC) has mandated that all credit card processors must retire version 1.0 of an encryption method called TLS (Transport Layer Security).

To comply with this directive, and ensure the highest standards of security and data integrity, Wild Apricot will stop supporting TLS versions 1.0 and 1.1 on March 12, 2018, but will continue to support TLS version 1.2. However, some older browser versions do not support TLS 1.2, so visitors to your Wild Apricot site may have to upgrade their browsers if they want to make payments on your site.

Below is a list of browsers versions that support TLS 1.2 and higher. You should encourage visitors to your site to check their browser version against this table.

Browser Minimum supported version Notes
Google Chrome Version 38 or higher Recommend using latest version
Internet Explorer Version 11 or higher Version 8-10 can be configured to support TLS 1.2 when running Windows 7 or higher
Microsoft Edge Any version All versions support TLS 1.2
Firefox Version 27 or higher Recommend using latest version
Safari (desktop) Version 7 or higher Use OS X 10.9 (Mavericks) or higher
Safari (mobile) Version 5 or higher Use iOS 5 or higher
Opera Version 50 or higher Recommend using latest version